Welcome to the world of Saab ! Register
Results 1 to 8 of 8
  1. #1
    Saab Owner
    Join Date
    15 Nov 2012
    Location
    USA
    Posts
    38
    Saab(s)
    2006 Saab 9-3 Aero
    Thumbs Up:   0

    Shaking/Jerking When Accelerating

    Whenever I am cruising in the 1500-2000 rpm range at about 50-60 mph and go to gradually accelerate the car jerks, almost sputtering-like until I release and resume on the accelerator. This occurs in fully automatic mode and also in the manual "M" mode (Generally 5th Gear). I also experienced this problem in a acceleration sprint @ 90 mph. It wasn't as violent, it just felt like something was slipping. The transmission seems to be shifting fine through all stages during acceleration and deceleration on both automatic and "M" otherwise. If I put the pedal to the metal, the jerking/sputtering does not happen. Any thoughts or diagnostics? The CEL is not on so I have no code to go by. I don't know where to go from here. My nearest Saab Professional is unavailable until Monday. Just wondering what to expect diagnostically and cost wise. Thanks in advance for any advice.

    2006 9-3 Aero, Automatic.
    ~93k miles

    -Cody-

    0 Not allowed!
    Last edited by cfrierson11; 11 August 2014 at 23:48.

  2. #2
    Saab Fan bjhiggi's Avatar
    Join Date
    14 Jun 2014
    Posts
    22
    Thumbs Up:   0
    Plugs and ignition coils

    0 Not allowed!
    Using Tapatalk

  3. #3
    Saab Fan harrissonsaab's Avatar
    Join Date
    17 Aug 2014
    Location
    Canada
    Posts
    22
    Saab(s)
    2005 Saab 9-3 Aero
    Thumbs Up:   0
    With 93k miles on it, it's definitely the spark plugs. I changed mines around that.

    0 Not allowed!
    Last edited by harrissonsaab; 17 August 2014 at 19:07.

  4. #4
    Saab Owner
    Join Date
    15 Nov 2012
    Location
    USA
    Posts
    38
    Saab(s)
    2006 Saab 9-3 Aero
    Thumbs Up:   0
    I appreciate the help. I pretty much narrowed it down to the spark plugs myself. Hoping to get some new ones in this week. Thanks again!

    0 Not allowed!

  5. #5
    Saab Enthusiast pisani01's Avatar
    Join Date
    28 Jul 2014
    Location
    taylorsville,nc
    Posts
    62
    Saab(s)
    01 saab aero
    Thumbs Up:   0
    I changed my plugs sorta felt what your talking about. Mine seems to be intermitent. Cel came on a few times and poited by code to the dic..but old plugs looked fine but light out now and still get that surging feeling at times let me know what you find out thanks

    0 Not allowed!

  6. #6
    Saab Owner
    Join Date
    15 Nov 2012
    Location
    USA
    Posts
    38
    Saab(s)
    2006 Saab 9-3 Aero
    Thumbs Up:   0
    Well it has been almost a week since I've had the plugs changed, and I must say she is running great. No more jerking, idling well, and much more responsive when I want to accelerate. Thanks for any help and I hope this post has help others.

    0 Not allowed!

  7. #7
    Saab Enthusiast pisani01's Avatar
    Join Date
    28 Jul 2014
    Location
    taylorsville,nc
    Posts
    62
    Saab(s)
    01 saab aero
    Thumbs Up:   0
    hope everything runs well

    0 Not allowed!

  8. #8
    Saab Fan Jerry512's Avatar
    Join Date
    17 Sep 2014
    Location
    Clifornia - United States
    Posts
    5
    Saab(s)
    2005 Saab 9-2x
    Thumbs Up:   0
    The issue mainly occurs with the ignition coils and plugs. Pay attention on both and replace them asap.

    0 Not allowed!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 15:42.
Powered by vBulletin® Version 4.2.5
Copyright © 2021 vBulletin Solutions Inc. All rights reserved.